Investigating elevated errors on the platform

Started
Lasted 44min
MAJOR

Updates

RESOLVED

lasted 44min

The incident has been resolved

INVESTIGATING

44min earlier

We're investigating an issue affecting Waterlily API service. Users may experience problems loading the app, saving changes, or using core features. Our team has been notified and is working on a resolution.